2.0 Alpha Test Build #0 (outdated)

NEW BUILD HERE: 2.0.0 Alpha 1 BB Firmware (latest beta, 2/18/23) - #3 by OnefinityCNC


This is the first build of 2.0 Onefinity Firmware.

This has a major rebuild that is 64 bit which will work with either RPI3 or RPI4.

Known Issues:
1366x768 resolution does not work on RPI4 Only


New features

  • Raspberry PI4 is now supported!
  • Added a new Wifi browser to the Network page
  • The Settings page now allows the user to rotate the screen when mounting it upside down
  • The Settings page now allows the user to set the time and timezone
  • GCode files up to 1GB are now supported, and progress is displayed during upload.
  • Support for many new types of gamepads (including XBox 360, XBox One, Playstation 4, Playstation 5)

User interface improvements

  • Rebuilt the user experience for probing to make it clearer, easier to use, and more informative.
  • The “Units” display on the main screen is now “Display Units”. Changing the setting only affects what you see in the user interface, and does not change the machine’s unit setting for movements.
  • Redesigned the top header, moved IP address and Wifi SSID to Network page
  • Redesigned the Network page
  • Many minor user interface improvements and tweaks

Bug fixes

  • Fixed the long/slow movement bug where the machine would fail long and slow movements.
  • Fixed the “stick drift” issue with some gamepads
  • Fixed the “stuck in jogging” bug
  • The Z-axis is now lifted by 25 mm (up from 3 mm) after a Z-axis probe
  • Screen resolution is now correct on all supported screens, and behaves correctly if the screen is plugged in after the controller has started.
  • Older controllers with a “toggle” style power switch no longer display “kernel panic” at shutdown.
  • Switched from disk-based swap to zram-based swap, to extend the lifespan of the controller sd-card
  • Rebuild the time/timezone dialog to work better with the virtual keyboard
  • The time is now displayed in 12-hour format, rather than 24-hour format
  • Improved gamepad support to properly recognize more gamepads
  • Added full support for the Logitech F310 gamepad
  • Added an item on the Settings page to change the default gamepad type
  • Added a “Remote Diagnostics” feature to the Help page, to allow support to gather information when diagnosing customer issues.
  • The most recently uploaded file is now selected after upload
  • Fixed a problem with uploaded files that contained “odd” characters
  • Fixed a bug that could cause the touchscreen interface to “hang” for up to a couple of minutes, after an estop
  • Brought back the “disable safety prompts” option for probing, with a warning about “living dangerously”
  • The “Save” button is now enabled immediately when changing anything on the Settings/Motor/IO/Tool pages

If you experience issues or bugs, you must comment on this thread for us to see them. This thread is the ONLY place the developers will look to fix bugs, if you don’t post them here, they will not be fixed. By downloading the link below, you agree to post about bugs on this thread, and only on this thread (and not on the facebook group, the developers will not see it there and any facebook posts related to 2.0 alpha builds will be deleted immediately).

Download Link:
ALPHA1_RPI_Kv_bbk_9.0-121022.img - Google Drive

Please share experiences here.

You will need to FLASH the SD card via this link (but with the above image):

We built this off of 1.0.9 as it’s the most stable build. We are slowly adding features to include the 1.1.1/2 feature set.

Builds off of 1.0.9.

Alpha Test 1 includes:

Improvements from 1.0.9
Incorporates 64bit programing.
New wifi looks like 1.1.1
New ‘welcome’ screen.

If you are running any ‘beta’ hardware (like z-20, etc) you will need to manually input those settings as they are not included in this build.

I didn’t get a ton of time to play with the new build but a few things that I did notice that I wanted to point out.

  1. On the initial bootup after it asked me to sign back into Wi-Fi, the next box does not light up. It was confusing on what I needed to do. I saw that “refresh wifi” but was afraid to hit it in fear of doing something I shouldn’t. I eventually hit the unlit Next button, then hit the blue refresh bottom and it rebooted.

  2. After it rebooted it got stuck on the loading last file popup. I could it said rendering 0% and never moved. I waited 3 min then decided to flip the power switch as everything was frozen. After I let it sit for a min I flipped the power back on and that time the render window popped up and quickly disappeared.

  3. Next step was to clear the settings, I went through all the screens and took pictures of my current settings then hit reset. Everything seemed to reset perfectly. I then rebooted without issue. However after dismissing the “do you want to home box”, and clicking through all of the settings pages to make sure they matched the pictures I took (which they did) I hit control, but the flyout handle that allows you to minimize the gray bar disappeared and no matter which screen I scrolled to I was never able to close that side flyout. That grayed out “save” did not click or action at all either.

Oh one last thing, on the first screen when it says pick your button. I was also very confused, had I not just watched the how to flash the SD card YouTube video I would have had no idea what to do there. It needs more clarification (maybe a graphic of the front of the controller or something) that lets you know you are selecting what type of power switch your version has.

I will play with it more this weekend when I have more time, but hopefully that is of some help. It does seem to me faster in booting up and the new loading graphic with the green pill bars that flow across is very cool.


Thanks Alex, these are great observations and will help us alot!

Start sequence, configuration motor settings all work as normal.
Issues with “change time/zone” does not prompt to save and time on control screen doesn’t match. (I’m not connected online).
Probe xyz and probe z and return to xy origin work well.
Slow response to open a new file…about 10 seconds before it registered on the screen as loading.
Biggest issue is with lag in screen time (see attached video)
Remaining carve time countdown is slow. Pausing the carve, the countdown continues until caught up
At end of carve, the remaining time showed 25 minutes remaining and continued to count down at slower rate than actual time and many function keys were greyed out preventing loading new file, zeroing an axis or return to home.

mitz, please attach that file that was running here so we can test internally.

1 Like

Leaf Tray 8x10x1 Finishing 0.06 tbn.ngc (1.6 MB)

This weekend I had a lot of OneFinity time, one thing that I noticed (minor issue) was that on the OF monitor it showed the time remaining in an odd way. However the pic taken a second later on the remote IP in view shows the time correctly.

Also interesting that the OF screen shows 24-hr format but my Web view shows 12h format.

Everything else seem to work flawlessly. I was having an issue an issue a few weeks back that when you load a new file (tried various files) they imported into the OF but did not load into the current to work box. So I carved a file that was a drilling file after I had already run it and switched to the v-bit file and the v-bit dove into the drilled holes… not fun. I slammed the estop and just clicked the file in the loaded files dropdown and it cut perfectly.


1 Like

Good Evening Team!

Yesterday I noticed a new bug in in the 2.0. When I booted up the machine it went to the load file flow and I waited 5 min and the file never got off 0%. It never asked me to Home, which I found odd as that is always the first step.

The file that I it was trying to load was one that I carved 3x of earlier in the week so it was not a file corruption issue.

Hope it helps, sorry I don’t have more to go on, but the picture I took.


Has anyone actually update their rasberry PI to 4 ? And if you have which version of 4 did you use?

1 Like

No end user has updated their pi to a pi4 as it was just released today.


Which version of PI 4 are you testing it on?

1 Like

I am probably out of warranty anyway… Original order in the #!4000s
If I crack open this controller, and swap out the pi… and I completely nuke things… are you going to “help me out” with a replacement?

A replacement is $500 usd plus tax and shipping currently :stuck_out_tongue:

1 Like

um… ouch. I guess if I nuke it, I will just wait for the upgrade program, order the new one and claim the controller worked fine when I shipped it back…

Your assuming getting your current controller back would be part of the program :stuck_out_tongue:

1 Like

Drats! Foiled again!

I do appreciate the banter. And for the record, I am not a person that would do that type of thing.
I have a few RPIs laying about. I just downloaded the firmware and will get it swapped (maybe) tonight. I will report back what I see and what features seem to work and which do not.

Do you have a document on how to swap out the rpi?


Cool! I’m curious if the pi 4 has enough CPU/ram for the gcode visualization to be enabled.

1 Like