Can't Figure Out the Drilling Tool Path

Hi All

Ever since I got VCarve Pro I haven’t been able to select a drilling tool path,

I’m sure its something I’m doing wrong but can’t figure out what it is,

I draw up some holes and then select some holes to drill, select a drill of the same size as the hole and when I select calculate I get a message that says “no toolpath generated for current parameters, check tool can fit in selected vectors at machining depth”

I’ve tried changing the drill depth to be shallower, equal and deeper and can’t figure what I’m doing wrong

Any ideas


I just did a 1/4" hole with a 1/4" end mill and it worked fine with both a plain drilling operation and peck drill selected. I have the raise above the material option picked.

What are your parameters? Can you grab a screenshot of the drill operation setup?

Heres two pictures with the tools settings’

IMG_2825 (1)

IMG_2826 (1)

You’ve got “project toolpath on 3D model” selected but you don’t show a 3D component. Uncheck that and the operation will calculate correctly.

1 Like

Jim , you’re a genius !




NP :slight_smile:

BTW, I tend not to use drilling operations. Even with a drill, those aren’t usually rated for the speeds we have on the router (although people do it all the time). The drills I have are 135 degree points which doesn’t match the standard ones you’ll see in VCarve so it’s one more thing I have to mess with as well.

I use a Profile cut with a Spiral Ramp instead. That’s pretty fast because my depth of cut is more aggressive than I’d want for a peck drilling operation and I just use standard end mills which are less susceptible to deflection than a drill bit due to the design of the cutting geometry.

Might be worth trying if you’re looking for more precision in your hole drilling. Although I can see where someone doing cribbage boards or something might prefer a straight drilling operation, the profile/spiral might be something you find useful for general use.

That’s what I’ve been doing because I couldn’t figure the drilling,

I agree that unless there very small holes I’d cut the hole with a end mill/slot mill,

and then you can adjust the size if its not exactly what you wanted.


One other possibility is that (per the Vectric people) an exact match between the hole you’ve drawn and the specified size of the bit in your tool library can cause this issue. Vectric had me put 4.999mm as the size of a 5mm bit and I haven’t seen the problem since.


1 Like

Good info to remember, but not the OP’s issue. It was solved 4 posts up. He told VCarve to project it on the 3D component but there wasn’t one in his project. He unchecked that parameter and was successful.