Fusion360 Syntax Error

I have followed the direction to upload the BuildBotics CPS into Fusion360 but I am receiving and Syntax Error. Anyone else receiving the same or know the fix?

1 Like

I haven’t tried - 1F said they were creating their own. Can you post the error?

1 Like

here is the .cps I am using.
buildbotics_jet (1).cps

Hmmm, super weird. Post processors are not written in XML and line 299 of the cps doesn’t look out of the ordinary. Can you do a Screencast showing your workflow (how you set up the operation and export the gcode)?

Alex (@MindOfMcClure) might have suggestions - I think he’s using Fusion and the pp.

In the mean time I’ll download the script and see if I get run into issues.


I just imported the post and ran it against an existing design without a problem. Are you sure you saved it as text with a .cps extension?


Man I am all new to this CNC and exporting Fusion360 gcode. My limited knowledge of how these systems work is minimal. So I have zero idea what you are asking. I was following a video class teaching about using Fusion360 as a cad/cam program.

Please ask or explain your question at a 5yo level.

Hey William - no problem. Maybe it would be easier for me to record a Screencast showing you what I did, and then see if you can reproduce it?


1 Like

Sounds like a great plan. However not a big issue right now. I am having other issues with the machine not recognizing Y axis home.

1 Like

Here’s some helpful info on adjusting the settings for homing:


1 Like

Hey Will!

When you were homing the Y axis, did you see it move forward to the front of the machine but stop before it bumped into the end? If so, you may need to start with the spindle closer tongue front corner. I believe I read someone else had this issue. The Z axis won’t turn green after homing until you set the Z axis zero.

Good luck bud!

1 Like

Man I have been trying to home Y from across the machine to just a few inches off the front left corner.

Check your instagram :stuck_out_tongue: It’s hard to keep track of all the different support threads different places :stuck_out_tongue:

In the last picture you sent on instagram:
You’re pieces is WAY to far forward. After a successful probe, it will move the bit to the front left of the probe. (the y direction). You’ll notice the error saying you don’t have enough room (the y axis will pass the limits) to move forward.


Here are the steps I have taken to try and extract the gcode.

I have dowloaded the user manual, watched the video paused the video and made adjustments, still no joy.

I think that would help a lot of people out! Please do!

1 Like

just trying to get my machine working.

I believe you should be using the buildbotics.cps post processor. The one you are trying to use seems to be for a water jet cutter. Make sure you have the correct one installed. https://github.com/buildbotics/bbctrl-posts/tree/master/fusion360. Then in Fusion 360 you should select Buildbotics 4-Axis CNC Controller. I have successfully used this post processer although at this point I actually prefer the generic grbl post processor already installed in Fusion. Still waiting for Fusion to make the Onefinity post processor!
Hope this helps!

1 Like

Agreed. I used the buildbotics.cps without problems. Try that and report back.

Can you grab a screen shot to explain? I am trying to grasp how to select the Buildbotics 4 Axis controller. I don’t see that option. I have used both BuildBotics cps.

Thank you

Well I see now that the one that I used was no the buildbotics.cps but the buildbotics 4-axis CNC. Buildbotics 4-Axis CNC Controller.json (198 Bytes) I have this file in the post folder of fusion.

Then in Fusion I am able to select that as the PP.
It does successfully generate gcode, although it seems strange to use a 4-axis PP. As I said I used it one time but for now I prefer the grbl PP. Why not give that a try? Its there already.

1 Like