Screen Lock on Boot


Newbie here and I have a problem. Just got my brand new journeyman Onefinity temporarily mounted to a sheet of MDF. Don’t have my table finished yet but wanted to start learning the machine.

However, when I boot the machine the 10" screen locks up. I need some help in trouble shooting.
My power is a 5 volt brick and I’ve tried using both USB ports with no luck. I’ve tried rebooting with the monitor power on and off when I turn on the controller.

The joystick works to move the machine ok but it doesn’t have the soft limits set so I’m not doing much until I figure out what’s wrong.

I was thinking maybe I could try another monitor but I don’t have one on hand.

Ideas please?

Sorry about your monitor troubles.
Check out this forum section.

Good luck,


10.8” Monitor: How to connect it to power and the controller

1 Like

Thanks Neil! This forum is awesome.

Problem solved. Operator error. Thanks to Neil for guiding me in the right direction. I didn’t have the 2nd “touch” USB connected. :frowning:

1 Like

Hey Michael,

Glad to hear you are on your way to making lots of wood chips, hopefully some fine looking projects.



eYou saved a lot of frustration Neil. I was pulling my hair out, what little is left.

I really appreciate the link to get me squared away


1 Like