Shutdown kernel panic (this is normal in Firmware 1.0.9 and below, removed in 1.1 and above)

Just getting my new Journeyman x-50 set up. Whenever I press the blue shutdown button it crashes. (See attached). I have to just turn the switch off. Any ideas?
Firmware 1.09

This is normal as of 1.0.9. Just flip the power switch when it gets to this point.

1 Like

Twice now I’ve gotten to this stage and the off switch doesn’t work. Switch off, computer/fans, etc keep running, screen unchanged. I just have to unplug everything. Switch has always worked starting from a shutdown but twice, can’t turn off. Any ideas?

I’ve only been up-and-running a week or so and I keep the unit under the desk and, as I mentioned, it always turns on so I’m doubtful it’s sawdust.

Back feed power from the screen usb.
Try turning off the screen or unplugging the usb that connects the screen to the controller.

You have no idea how long i struggled with this as part of a larger problem. I’m not sure if you are experiencing some of things i was seeing along with the Kernel Panic, but basically I was seeing 3 things…

  1. Kernel Panic on shutdown
  2. If ANY GCode file was loaded on the controller at the time of reboot after the Kernal Panic the 1F would hang on start up with a “Processing New File” modal dialog box.
  3. Deleting all the GCode files via SSH to get around the Processing New File problem would result in the controller not homing and not being able to jog after start-up. The only way to work around this was a series of E stops and reboots. However if i left any GCode on the 1F i’d get stuck in this loop again and the Kernel Panic was there on every shut down and i suspected it was part of the problem.

Long story short, I don’t think the Kernel Panic is normal as once i figured out the root cause of all the problems I was having the Kernel Panic went away along with the other issues. In my case the root cause was the web camera. If the web cam was plugged in when the system was shut down it would cause the Kernel Panic, and I believe it was causing some I/O errors that resulted in it hanging at startup during the Processing New File step. I can still use the web cam…but I make sure to disconnect it before shutting down, and i don’t plug it in until after the 1F is up and running.

I’m not sure if you’re problems are at all related to what i had going on but figured i’d share in the event you are headed down the same path and I hope this helps you avoid a lot of the time spent trying to figure this out. Support was a great help and they even sent a replacement controller thinking mine was faulty, but the problem was easy to reproduce on the new controller as well. Hopefully there will be a firmware upgrade to address this issue. There seem to be processes not terminating properly at shut down and unhandled exceptions in the code that cause it to hang during the Processing File step when starting up, in my case all related to I/O errors with the web cam.



Sorry, I don’t know what “back feed power from the screen usb” means.

But if it’s potentially a USB thing, I have a thumb drive in a USB port occasionally when I shut down. Could that be causing the problem? Also, sometimes it’s connected over wifi to my Mac when I shut down. I was going to take those two things out of the equation next to see if that makes a difference. Think it might?

Ugh! I feel your pain. Yes, I’m experiencing that too. My next step is to make sure there’s nothing plugged into USB, nothing connected via wifi and no code loaded into the system before I shut down. Maybe that will help. Will let you know. Thx!

in my case disabling wifi and unplugging the LAN cable didn’t do anything to help. what i will say is that when i figured this out it was after (one of the multiple times) I reinstalled of the OS. All the previous times i reinstalled the OS the problem simply came back, but the last time i reinstalled the OS suspecting it was the web cam, i simply started fresh and eliminated that from the equation and the problem didn’t come back. So i can’t verify if you are having the problem if you simply eliminate the USB camera that things will self correct without reinstalling the OS. it’s worth a shot…but if it doesn’t work i would reinstall the OS and simply eliminate the USB camera. Your system may be hosed and not able to recover

I bought a Woodworker about six months ago. Yesterday, this problem occurred for the first time. Thinking the SD card was corrupted, I got a replacement and re-flashed it with a new instance of 1.0.9. It still happens.

I noticed that when the power is disconnected, the stepper motors stop humming, but the Raspberry Pi keeps running. Unplugging the USB connector for the touch screen the power down; so it is getting back-feed through the monitor.

My biggest question is why did it just start now. I tried resetting monitor. This did not change anything. I assume there is some setting in the monitor or the controller that was changed by accident. It would be good to get it back to where I can shut it down remotely and trust that it will actually shut off.

BTW… No camera connected during all this.

I have the same problem with mine. I received my Journeyman in January and I just finished putting it together for the 1st time (waited before I got to build a cabinet for it and fitted it with a spindle and VFD).
Anyway, it worked fine the 1st couple times I powered the controller down during my tests, but now it ends with that (same as shown above) kernel error every time.
I tried all the things suggested in this post but nothing made a change. Pretty disappointed and worried since I haven’t even started to make my 1st cut.
What’s even more concerning to me as a newcomer into this brand, is the fact that 1F offers no solution after all this time, and the Onefinity Support Leader post here saying that this is somehow normal. I don’t know much about this controller, but in the computer world -kernel issues are never OK, especially when they control physical hardware or machinery which could lead to loss of tools, material, or even accidents or harm.
From the info I gathered so far on this, it looks like this is definitely a software or OS bug and should prompt for a new release to fix it.
Has 1F or anyone else found a solution to this issue?

There’s no ‘solution’ as it’s not a problem. It causes zero issues with the machine and normal. Shutdown per usual.
(see: Proper Shutdown on the Onefinity CNC)

RobPage,
I believe what they mean by “back feed power from the screen USB” is: The touch screen is powered by its own power supply and power jack… the screen is also connected to the controller via a USB cable. When the controller is powered down, there is still power on the screen USB from the screen power cord. That will (occasionally) prevent the controller from completely shutting down.

What I do when this happens is pull the power jack out of the touch screen (I believe its the top plug) and the system loses power that is feeding the controller through the screen USB, and the system immediately shuts down.

I do not know what causes this as it only happens every so often… but I suspect that it may have something to do with high operating temperature. My 1F is in my garage, and it has been hot when I have noticed it happening… Thats just a guess… but I know that on occasion I have been well into the upper 90’s (deg F) when it happened… so far it hasn’t happened early in the morning when it is cool(er). We’ll see this fall and winter if it keeps happening.

2 Likes

There are “data only” adapters for USB that can prevent the power back feed issue. I have used these on a couple 3D printers when fitted with a Rasperry Pi for Octoprint.

image

3 Likes

Thanks! I’ve got one on order…

1 Like