"Disconnected" Pop up after stopping the job. Only way to regain control is e-stop?

Good day, Everyone.

Just got my machine, been experimenting.

I noticed that when I stop the job using the stop button, I can no longer move the machine axys using the button. As the matter of fact, I can’t control any of the axys at all with neither homing, nor the directional buttons. I have to press the big red e-stop switch in the web interface but then re-home the machine.

Is there a way to release the machine after prematurely stopping the job?

1 Like

I would just recommend pausing the carve rather than hitting the stop button. Then you can just hit the play/pause button again and it will continue with the carve.

It’s more the fact that I have to actually stop and load a new file during experimentation. It seems weird that the whole machine locks up with that “disconnected” popup just because you pressed stop. Shouldn’t you be able to just stop a job at any point without it requiring you to press the e-stop red button thus forcing you to lose your homing?


Yeah happened to me too. Idk what to do if that happens. I’d like to be able to set my zeros run a file and have the ability to stop it mid carve and have it return to my Zero (or not disconnect and make me reset where my zeros get lost) where I can load a new file and run it from that same zero without having to rezero stuff.

1 Like

I was kinda baffled that I didn’t find more forum posts on this issue. Is condemning your machine into cartographical purgatory just to stop a launched job considered the norm with this machine? I mean even my cheap Chinese 3018 tabletop cnc remembers where it left off when I stop the job.


I’m not sure. I mean I guess the workaround is if you home the machine and then you know the positions of the zeros from the home origin but I normally don’t home and when I find my zero I pretty much don’t move it from there since I do the same project a lot. But I ran into the issue where I was running the gcode and needed to stop it and run another gcode given that I don’t mind that it has already ran some. I hit stop twice and it disconnected everything. I want to try and hit pause then stop next time and see if that works like we need it to. But for sure stop twice messes things up.


I feel like the disconnect thing is a 1.0.7 bug. I saw it once or twice on 1.0.5 and see it a ton on 1.0.7 but it never fails a cut

1 Like

I’m not sure if I saw it before 1.0.7 or not but yeah this is the only issue I’ve ran into beside the laser m3sxxx
shutting off while moving which is a known issue. And this issue doesn’t happen to me a lot given I don’t stop my projects mid cut normally but when I do I’m not sure the best way to do it and keep my zeros and stuff while uploading a new code.

When you hit stop are you hitting the square black box or the estop? I have gotten that pop up but it just means I didn’t hit stop (black square) after pausing if I remember right. I know you can bypass the pop-up. Try hitting that stop button and then xy0. I just can’t remember for sure off the top of my head.

The black square button.

On the side note: I had a one on one chat with a software dev this morning and when I attempted to replicate the issue, it stopped. Literally machine would no longer lock up at the mere presence of the dev. So Frustrating. So I think that it IS supposed to relinquish the control to the operator but some minor elusive bug was preventing it from doing so.

I’ll try to catch the issue next time it occurs.

1 Like

That’s how it always works lol. I’ll try it again when I’m back out in the shop also. Maybe it was just a bug.

If you mean - it’s supposed to lock up then I don’t think so. Because today during a test, when I pressed stop, it let go just fine. But the day before it would lock up and any time I pressed any of the movement buttons, the “disconnected” message would pop up.

Nice maybe it was just a bug. I’ve only pushed stop twice I believe and I got the disconnected message both times so I figured it was always like that. Glad to see it isn’t.

Miles - welcome to the forums. I had this happen once - thought it was fluke so I disregarded it. I did have to reboot my machine to regain control which was very annoying. Perhaps it is a bug of some sort, though I don’t know what the variable would be. Might be work investigating further.


1 Like

I have experienced this also. I saw where Roger Treadway (20 days ago) had posted the first time he ran across the error. I had the same error and situation but I have been waiting for someone to come up with a fix since I am a new cnc user and don’t totally understand everything that is going on yet.

I can tell you this. When the cnc first arrived and firmware version 1.0.5. was being used the machine never did this. Once 1.0.7. was updated and installed I saw this error. The only way I way to get control of the machine was to shutdown and restart the machine.

Is this a flaw in the new firmware? I remember hitting stop while using 1.0.5. and the software did what it was suppose to do, it stopped the program and you would have to restart from the beginning. You still had control of the machine and you still had your zero points.

1 Like

Yeah I posted on here a few weeks ago when I had it happen to me but didn’t get any answers if it was a bug or something but I’ve been seeing other people saying now that’s it’s happened to them too. So maybe it’s a bug with the new firmware. Maybe someone that has the answer will see these posts and let us know.

I think had the issue on 1.0.5, since I only recently upgraded to 1.0.7 like 2 weeks ago. Though I certainly had it happen during my last run - which was caught on film in my last video. I deleted all the restarting and rehoming stuff from the video though. Hopefully @OnefinityCNC is taking notes and submitting a DR internally.

1 Like

I had caught the error again today. We went through the issue with the support falls and submitted an error report. using the onboard bug report tool. Hoping this is gonna help.


This happens to me, too. When I hit “stop” (not eStop), I get “Disconnected” … no joystick control, no resume, etc. Like @Almtchncn said last week, I wasn’t entirely sure it wasn’t my fault (being new). Only remedy for me so far is to restart machine.

is everyone here on 1.0.7 firmware?

1 Like