Firmware 1.3.0 Alpha 2 (outdated)

This thread is closed as newer firmware has been released here: Firmware 1.3.0 RC1

This is the alpha version of firmware 1.3.0.

Alpha 2 includes:

  • Fixed G-Code selection (incorrect files loading when uploading new gcode, known issue in 1.2.1)
  • VFD 60 (PwnCNC vfd included in dropdown
  • Front end logging for G-Code and Probing issues (for use when reporting issues with firmware)
    Added in Alpha 2:
  • Added Verification after probing is done. (Should solve ‘hanging’ probe issue)

Download here:
1.3.0 alpha 2 (OLD FIRMWARE)

How To Install:
Updating via USB
You’ll do an update via USB using the following steps:
Copy the blue .bz2 file above onto a usb stick (it must be formatted as fat 32 or ntsf). Click the flyout menu (three bars on top left), general, under firmware click ‘UPLOAD’. Select the 1.3 file.
If you are on firmware 1.0.8 or lower, it may ask for a password.
the password to update will either be buildbotics or onefinity


Hi @ahandeman ,

Thanks for the feedback. Can you please help us with the logs and steps to reproduce the issue?

May I know how frequently it is happening?


X50 JourneyMan
Onefinity Probe.
No Gcode uploaded or stored


Prob X Y Z
Prob lower-left corner of material ( 1 inch X and Y axis from home location )
After prob complete. Move z axis up to install dust collection brushes.
Moxe X Y axis back 2 inches.
Click the home button,
Receive the following error message.
I get a different error message every time but always says less than the soft limit.

The only way I found to resolve it is to reboot the system.

I reflashed and Installed firmware. 1.2.1, repeated the same steps, unable to reproduce the error messages.

1 Like

@139working , this is not an issue with the firmware. It’s because you didn’t do all of this: Help! My Toolpath says 'Under' or 'Over"! (with videos)


Hey Dan,

By the way, there is a search function on this forum

1 Like

Thanks, I have done all that. Again only happens in 1.3.0 alpha, I can not reproduce in Firmware 1.2.1
Thanks for the feedback

I’m in a situation similar to that of @139working.
Tried to make a pocket and I had this error message:

Machine was Homed and Zeroed as I already did many times with the standard firmwares. It never happened before, only with the alpha firmware.

I have been able to solve the issue rebooting the machine even if it randomly appear again. I do confirm buttons sometimes turn green off and on randomly.
Anyway even if it’s not in error, the depth of the cut is not correct: it’s more or less double the expected measure.

I’ll investigate further.

Is your probe and probe magnet intermittently touching? I saw this when they sat near each other, and the vibration caused them to touch.

can we bring back the bigger web cam view? seems like every update the screen gets smaller and smaller, some of us are old and like to watch our monitors from 50 feet away while watching tv lol

1 Like

Please post a detailed, narrated video so the developers can take a look. include reproducing the issue in alpha 2

1 Like

Problem solved after a new machine reset :grinning:


Hey all,

Interesting to see this Alpha version up for almost 1.5 months and see very little activity here other than the classic “Under & Over” issue. The good news is that I don’t see a ton of bugs being reported but I also don’t see many of the most active users/contributors (the ‘usual suspects’ that we rely on so much; thanks again) saying that they’ve upgraded to v1.3 and are so very happy with the results. I’m in the process of installing my PwnCNC spindle and would love to see the VFD in the dropdown.

So, how about a roll call of thrilled v1.3 users??


I have been using v1.3.0 alpha1 along with my PwnCNC spindle with no issues so far. I haven’t updated to alpha2 and was kinda hoping to see a 1.3.0 Final at some point.


Hmmmmm. Not too many folks responding. Is everyone just staying on 1.09 for now?

No issues have been found in alpha 2.
We’re finalizing this release for general public release soon.


Wow!! “No issues” is almost too good to hope for. Looking forward to upgrading when the coast is clear.

Thanks for the work.

1 Like

I hope that you updated the ability to control the travel seed on the fly when running a job, but my guess is that you don’t care.

Congrats to Onefinity for getting us over the line. Looking forward to upgrading from 1.09.


I upgraded to 1.3.0 Alpha 2 today and ran a few quick tests today. Things seems to be working nicely so far. I like the new sort ordered by upload date descending in the ui dropdown. That probably helps reduce the chances the wrong file gets selected when the 1st file mistakenly gets selected after upload. (i had previously uploaded a BLANK.gcode file in that spot (with the old case sensitive alpha sorting) that prompted me to attach the probe just in case).

Thanks for the continued work on the firmware!

edit. i uploaded files from a remote web browser, xyz probed, used gamepad, ran some gcode files selected in both the local and remote browsers.

1 Like