Help! Losing “Home” during carves

Yes, they sent an assembled right side.

1 Like

Well pretty good of them.
I wonder if they’ll do the same for me as I’m having the exact same thing happening.
When I saw your video, I felt like I was watching my machine. Lol

So they are sending me a new Y rail assembly. Just curious if you installed your new one yet and if it solved your problem.
By the way, I was just in the middle of a huge cut, 29x29 and it lost its position

I did install the new rail and it did solve my issues. I have not had a loss of home failure since then. Glad this will be behind you. Gotta love OF tech/customer support! Best in class for sure!

Good luck to you on your future carves!

Hey Eric, hey all,

after carefully having followed the whole thread I still find this disturbing. Can you, or can someone say what really is the cause of this issue? If loosening ball nut screws or putting shims behind the shoulder of the ball nut makes the issue better, is the gantry block not milled square? Or is the ball nut shoulder not square? Or the ball nut of minor quality? Or the ball screw warped?

I didn’t actually take apart my right side Y axis to determine the issue. That would have been my next step if I didn’t get resolution from tech support/ customer

I can say that the ball nut did fit into the gantry tightly. Actually the fit was considerably tighter than the left side ball nut fit. I had to loosen the ball screw nut and pound the end of the ball screw to get it out of the gantry block.

I don’t believe the issue was bad machining, though I don’t know for sure. My guess is that it was a few small issues, like the smallest allowable size gantry hole with a maximum allowable size ball nut exterior.

I did ask tech support to let me know what they found with my right aid y axis but have not heard anything in this regard.

My issue has not returned since I swapped out the right side y axis.

3 Likes

I’m having this exact same issue. I have more failed cuts than successful ones. I’ve eliminated dust being the easy explanation and I’m still losing home on long cuts. I’m going to try these proposed diagnostics and resolutions tonight.

Jason - any updates on this?

We took about a week or two off on cutting to order in a dust boot and upgrade our dust collection system as the general consensus from the community last time was that this was a dust issue. We have 3D printed ball screw cleaners, draped some fabric next to inside of the rails, got a 3 HP dust collector, etc. My buddy booted her up today for the first time to run a simple sign cut. Just sent me this:

Still gathering thoughts on what happened but at first glance it looks like she lost Z and just walked through the piece.

This continuously happens. I’ve already had to replace a spindle because the last time it did this it destroyed the bearings. My friend and I just want to cut simple things I make in Fusion… My old Shapeoko never had these issues. Sorry, I am beyond frustrated at the moment. Any assistance would be appreciated.

I don’t see any email to support@onefinitycnc.com? Why frustrate yourself before contacting us?

1 Like

I’ve definitely emailed support before, around February 2nd, and was given the aforementioned dust advice along with a sort of common solutions step by step guide. Are you referring to emailing you about this issue today? It just occurred and the community is a great resource for advice?

Only see an email about a seized motor.

Is your router/vac on a separate circuit than the controller/screen? Do you have drag chains?

Yes, the spindle is on a separate system since it is 220V. The dust collection system is on the same circuit. Before going down the rabbit hole of dust being an issue I can tell you that it isn’t. The system was working fantastic while running the cut, everything clean and operational, just as it should be. Yes, we have drag chains set up as well. This machine has truly been nothing but issues. To date, I am not seeing how it was rated so high in its class. I am hoping that we can get proper educational responses so we can resolve this constant failure after failure that we are experiencing.

Just to add more clarity to this problematic machine, I personally maintain the machine prior to EVERY cut, cleaning and applying oil to ensure the proper operation of the machine. More importantly, I had a new electrical panel professionally installed along with my house rewired so that I could ensure our workshop is fully functional.

How many more thousands of dollars do we need to pour into this machine so we can get the advertised results?

Please advise.

1 Like

You should email support@onefinitycnc.com. You should have emailed long ago :slight_smile:

I emailed support describing what I thought was a seized stepper motor and was told it was a skipped step from failing to keep the machine free of dust. Then we eliminated dust being an issue and are still experiencing failures. I mean, I’ll send you all this in an email…

You should have kept emailing support as you never responded to supports email.
Support is done though email, not the forum.

My apologies, the support tab on the main Onefinity website lists this forum where your account, Onefinity Support, was providing support, under a category called troubleshooting, in the form of a link that took me to a FAQ troubleshooting support guide on the same forum.

That’s my error.

We are compiling an email to send to the support email address to follow proper procedure.

In the interim, if anyone in the community has had similar experiences and might provide any insight we would be eternally grateful.

1 Like

I haven’t had anything similar, the Onefinity has been rock solid for me and any failures I had were self inflicted (like selecting the wrong g-code file from the drop down menu 6 hours into a project). Most times I’ve seen someone report an issue where the tool took an unplanned route through the project it was due to dust build up (you’ve checked this already), a loose grub screw connecting to the ball screw or EMI/RFI or electrostatic discharge causing the issue, however those seemed to be random moves through the part or in one axis. The failure you show seems to be in all 3 axis, Z height too low, X and Y seemingly moving in a straight line at an angle and distance that isn’t parallel to anything else on the workpiece which would suggest it’s not a single failure like a stepper motor or electrical connection. EMI/RFI/ESD are possible causes - I haven’t run into these personally but I did ground and bond all the metal parts of my machine on day 1, I run a spindle and it is grounded (not shielded cable), my dust collection hoses are all conductive so they dissipate any build up of ESD to the metal dust collection piping system which is also bonded to ground.

If I were to make a suggestion it would be to install a ground to the metal chassis of the Onefinity to give any ESD a path that isn’t though the Onefinity controller. I used one of the bolts in the foot securing the Onefinity to my table.

3 Likes

I’ve had my share of headaches with this machine. It sucks when things aren’t working the way they are supposed to. Support have indeed helped me through my problems. Yes email is the best way to go, they have responded at odd hours which is appreciated. And they are quick with replacement parts, sometimes no questions asked, straight up replacement.

1 Like

Thanks for the advice. Per support’s request we are going to take the machine back to out of the box factory configurations, no accessories, and run through some tests. I do hope we have documented behaviors come to light under the tests which quickly and definitively point us in the right direction for a solution. From the OP’s tales, it sounds like pinpointing EMI/RFI/ESD would be exhausting but we will cross that bridge if it comes to it.

I’ll keep anyone who is interested posted with our progress and of course welcome any continued advice and encouragement.

1 Like