Saving a tool path

Can anyone tell me how to save a tool path so my controller can read it. I have a Woodworker.

1 Like


Can you be a little more specific? GCODE files are .nc files and you can create and save them in a file editor like “Notepad++” but also your CAD program creates them as part of the process. Did you write a tool path by hand in GCODE or are you using software?


1 Like

Hey Steve,

this is a frequently asked question. The answer is: You choose the right post processor in your CAD/CAM Software and then you export the toolpath. What the exact menu item is that you got to click to export it depends on which CAD/CAM Software you use. You can find this out if you read the fine manual of your CAD/CAM software (often nowadays there exist helpful tutorial videos on the CAD/CAM’s manufacturer’s home page).

Did you already choose a CAD/CAM software? You did not tell which one you use, or want to use.

For example, with Vectric, a popular CAD/CAM software, you can get a free unlimited time trial version with a few restrictions. This allows to get to know the software before you buy an unrestricted version, which is also possible thanks to the rich video documentation. Generally I would start early and go through the following very helpful information:

As @MindOfMcClure already mentioned, you can also write G-code without a CAD/CAM program. Before the advent of CAD/CAM software, this was the usual way to use a CNC machine.

You need no special program to write plain G-code. As G-code consists of plain text, any text editor program will do. After having written your G-code as plain text, save the file with a ‘.ngc’ file ending which will allow it to be recognised as g-code file by the Onefinity CNC Controller when loading the file. More information here.

1 Like

I made the toolpath in vcarve. I tried to save it to a usb drive formatted in fat32. My onefinity controller will not read it. I have a woodworker cnc.

I am using vcarve pro

Hey Steve,

you are really sure about it formatted with FAT32, and not exfat?

Do you get an error message, or does your file simply not appear on the loading file dialog? Is it ending with .ngc / .gc?


The USB needs to be a 2.0. Ver 3.0 will not work with Onefinity Controller. Hope this helps

Hey Paul,

this is still often claimed, but it is not true. USB 3.0 flash drives work perfectly on the Onefinity Controller, because every USB 3.0 device is downwards compatible by design.

What might not be supported because of the age of the underlying Operating System in the Onefinity Controller, is exFAT Filesystem found on practically every USB drive bigger than 32 GB nowadays. If your flash drive is not recognized by Onefinity Controller, you have to reformat the flash drive using NTFS or FAT32 instead. :slight_smile:

exFAT Filesystem is supported natively since Linux kernel 5.4 but I have no idea if or when Onefinity will switch to a newer version of the underlying OS.


I am 100% sure it is FAT32. No error message, It just does not appear when I click on “upload a new gcode program” on the icon that looks like a open folder. This time the file says “Tap File” The first time it said “Veitric CRV File” I have tried to save it different ways. It may be the way i’m trying to save it in vcarve.

I am using vcarve pro. I think it may be the way I am trying to save it.

Hey Steve,

How can I find the correct post processor for my machine tool?

SOFTWARE: Aspire, VCarve, Cut2D

When you initially open your Vectric product for the first time Vectric’s ‘Kickstarter’ wizard will run, The ‘Kickstarter’ wizard will give you the opportunity to select your CNC machine. The ‘Kickstarter’ wizard not only ensures that you have the right post-processors and machine configurations straight-away, but the management system also allows you to optionally stay up to date if relevant newer post-processors for your machine are released in the future all from within the software.

When you open the “Save Toolpath” form your machine and post processors will show by default.

If you are not sure of the correct post processor for your machine, you can contact the machine’s manufacturer or distributor, ask on the manufacturer’s forum, ask on the Vectric Forum, or contact Vectric at

– Source: Vectric FAQ

The information you need, provided by Onefinity CNC, is here:

Tap files and Vectric crv files are the wrong file types. Those cannot be opened by the Onefinity Controller.


This is what Vcarve looks like when I try to save it.I don’t know if I am doing it correctly.

Hey Steve,

you need to save .ngc files.

Do you have Vcarve Pro Version 11?

If not, if you have Version 10.5 or lower, you need to install the post processor manually, as explained here:

1 Like

This is what vcarve looks like when I try to save a file.

Do you have Vcarve Pro Version 11 or higher? Then you should be able to simply choose the Post Processor called “Onefinity (*.ngc)”.

If not, if you have Vcarve Pro Version 10.5 or lower, you need to install the post processor manually, as explained here:

1 Like

This is what the Machine Configuration Management look like.

Hey Steve,

all you need was already answered above.

Looks like you didn’t download the machine configurations from Vectric. Hit that cloud download icon in the top right. Once you do that it will ask you for vendor, etc, and set things up.


It is vcarv version 11.5

Hey Steve,

then it is likely that @Atroz’ answer is the solution to your problem! :slight_smile: