Modbus configuration problem

I have a Huanyuang spindle. My modbus status says connection timed out, status 0, speed NaN. Spindle will not come on. It worked fine yesterday.

Yikes, that doesn’t sound good. I’m assuming you’ve done the obvious power-cycle/reboot of everything. I’d also double-check your wiring to make sure nothing has come loose.

If none of that works, I’d switch the VFD to manual speed mode, to see if the VFD can still control speed correctly with the dial.

rebooted numerous times, all connections are good, vfd works in manual. Controller is not communicating with vfd.

Well, the next step would be to see if the 1F is outputting signal or not. Unfortunately, I think an oscilloscope is needed for that diagnostic. Or, swapping parts (VFD or controller) to see which one is the cause.

Not sure what you mean Mike

Hey Dave,

have you checked this

Well, one of 3 things must be wrong:

  1. The OneFinity Controller is not sending a signal.(controller is broken)

  2. The Controller is sending a signal, and it’s not reaching the VFD (wire/connectors are broken).

  3. The signal is reaching the VFD, but the VFD is not responding correctly (VFD is broken).

I’m assuming that since things worked before, it’s not a configuration problem.

As @Aiph5u suggested - the breakout box has been a source of problems in the past. That would fit in category #2 above.

A multimeter can’t measure the signaling on the line - an oscilloscope would really be needed. I don’t have very much experience using them though.

Otherwise, swapping out parts to see which one is broken is the only other thing I can think of.

Breakout box is OK. I checked the voltage going to the RS- and RS+ terminals. RS- is 1.73 v and RS+ is 1.47 v. So controller is sending out a signal. Don’t know if those voltages are the ones required.

Hey Dave,

Onefinity is using ISL83485 and is driven with +3.3 V as Vcc, what you are measuring is A/Y - B/Z pins, so probably 2.7 V, signal should be measured between A and B of interface (between pins 13 and 14 of DB25 connector). If you have no oscilloscope, a multimeter should be set to “AC”. If you measure while VFD and Onefinity CNC Controller are connected to each other, you cannot know from where the measured voltage comes. I would suggest to measure on both devices separately while they are separated.

Be sure that either PD001 or PD002 or both on VFD are set to “2” and that the communications options are set identical on both VFD and Onefinity Controller, as described here.


I don’t have an oscilloscope. In the numbers I stated above the controller was not connected to the vfd. So with the controller and the vfd separate using DC and measuring 13 to ground I got 1.47 V and measuring 14 to ground I got 1.73 V. Measuring the DC between 13 and 14 I got from .22 V to .29 V. On the vfd measuring -RS to ground, +RS to ground, and the DC voltage between them I got 0. Switching to AC 13 to ground fluctuated from .065 to .12 V. AC 14 to ground was .08 to .10. The AC between them was .179 to .240. Measuring AC at the vfd, -RS to ground, +RS to ground, and -RS to +RS I got 0. This is leading me to believe the communication circuit in the vfd is the fault.

Hey Dave,

the probable reason you don’t see 2.7 Volts is that a running serial communication is neither DC nor really AC. But when it showed that it is zero on the VFD, the multimeter fulfilled its purpose :slight_smile:. I find it very sad if your VFD doesn’t work with RS-485.

I got to say that the cases where a cheap chinese VFD simply does not get to work with its RS-485 interface, even if experienced users help, are not really rare. I don’t want to bring you down but it happened to others.

I see above that you already checked everything else, so I have no further idea.

The other day I found that with Huanyang VFDs there is an important jumper not mentioned at all in the manual, and it was important for getting the speed knob on operator panel to work, and others report too that it is a mess with their manuals. Only if you look at the manual I can only stay away from that. If I may, I may also refer to my soapbox speech from the other day :slight_smile:.

When I had to look what I had to configure on my VFD in order to use it with my spindle and my cooling station, I did not need the help of a WWW search engine or of Youtube. Not even once. This is because a good device is also good because it has a good manual. The manuals of the mentioned components, especially the manual of my VFD, were absolutely enough.

(Note that I am neither affiliated with オムロン株式会社, Kyōto nor with Mechatron GmbH, Pfungstadt).

Of course this is a forum of a manufacturer that mainly adresses to hobbyists and many people would prefer to try out low-priced products first before spending more money. But in detail, one can often see that the price differences are justified by certain things like reliability, and one can also understand that letting technically well-trained authors write a very good technical manual in an easily understandable language (and this in many different languages) has its costs that one has to pay if that is wanted.


Thanks for your help. I’ve set the vfd back to manual operation. At least that part works. I’m thinking when the Hitachis become available again (apparently they’re all on backorder) I get one.

Hi dgentner,
I’m having a very similar issue to yours. Where you able to fix it?

Everything was working flawlessly until a couple days back when I noticed the spindle stayed on when a program ended. I also noticed that the spindle rpm’s are not being displayed anymore. Connection trough the modbus appears to be ok, but once the spindle starts, it shows a timed out status. Only way to stop the spindle is by the stop button on the vfd. Once the spindle fully stops, the connection status go back to ok.
I’ll appreciate any help!

I’ve recently had a friend who is an electronics design engineer at a machine tool company check why I couldn’t get my Modbus to switch the spindle on and off and he suggested it was the Chinese inverter and to buy a better quality inverter


1 Like

Hey Jose Alberto,

if the ModBus communication breaks down during spindle run, but is established back again when spindle is stopped, this sounds not like a ModBus configuration problem but rather like an EMI issue.

A VFD and especially its output cable, the cable to the three-phase spindle, are heavy sources of EMI. Therefore it is required to use shielded cables, also a VFD is intended to be installed into an earthed electrical cabinet. Both should be indicated in your VFD manual, including which wires to use, on a page that should look like shown here. As you can see there,

  • for the signal cables like used for ModBus communication, you should use shielded, twisted pair cable.

  • On the output of the VFD, i.e. the spindle cable, you should use shielded 3+PE for the three-phase spindle, like shown here:

Image 1: A typical spindle cable for use in a power chain (LAPP ÖLFLEX® CLASSIC FD 810 CY )

See this thread for more information.

Cables especially made for drag chains are e. g. LAPP ÖLFLEX® CLASSIC FD 810 CY or IGUS chainflex® .

1 Like

I appreciate your suggestions. I will post my findings if I’m able to fix this issue.